Nowy Ionic (5) na starym Androidzie (4.4)

Zostawię tutaj hint jak sprawić, że apka w Ionicu 5 zadziała na starym androidzie 4.4.

W pliku polyfills.js należy na końcu dodać takie coś:

if (window.hasOwnProperty('NodeList') && !NodeList.prototype.forEach) {
    NodeList.prototype.forEach = function (callback, thisArg) {
        thisArg = thisArg || window;
        for (var i = 0; i < this.length; i++) {
            callback.call(thisArg, this[i], i, this);
        }
    };
}

Testowałem z WebView w wersji 4.1.1

Skomentuj